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This guide describes how to use Podcast Composer to create 
Podcast Producer workflows.

Mac OS X Server includes Podcast Composer, an application for creating and deploying 
Podcast Producer workflows.

Important:  Before you read this guide, make sure you familiarize your self with 
Podcast Producer workflows by reading the relevant sections of the Podcast Producer 
Administration guide.

What’s in This Guide
This guide includes the following chapters:

Chapter ÂÂ 1, “Podcast Composer Overview,” provides an overview of the Podcast 
Composer application.

Chapter ÂÂ 2, “Configuring Basic Workflow Information,” describes how to set basic 
workflow information such as workflow title, copyright, and description.

Chapter ÂÂ 3, “Configuring the Import Stage,” explains how to specify the source types 
of the input movies that your workflow processes.

Chapter ÂÂ 4, “Configuring the Edit Stage,” covers podcast branding, which can include 
adding a watermark and introduction, title, and exit movies to the input movie.

Chapter ÂÂ 5, “Configuring the Export Stage,” shows you how to specify the types of 
podcast you want your workflow to publish.

Chapter ÂÂ 6, “Configuring the Publish Stage,” describes how to specify podcast 
publishing destinations.

Chapter ÂÂ 7, “Configuring the Notify Stage,” describes how to create notifications to 
announce the publishing of your podcast.

Chapter ÂÂ 8, “Managing Workflows,” explains how to save, verify, and deploy your 
podcast to a Podcast Producer server.

Chapter ÂÂ 9, “Advanced Podcast Composer Topics,” discusses advanced Podcast 
Composer such as customizing the email template and extending workflows.

Pr
ef

ac
eAbout This Guide
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Note:  Because Apple periodically releases new versions and updates to its software, 
images shown in this book may be different from what you see on your screen.

Using Onscreen Help
You can get task instructions onscreen in Help Viewer while you’re managing Mac 
OS X Server v10.6. You can view help on a server or an administrator computer. 
(An administrator computer is a Mac OS X computer with Mac OS X Server v10.6 
administration software installed on it.)

To get the most recent onscreen help for Mac OS X Server v10.6:
Open Server Admin or Workgroup Manager and then:mm

Use the Help menu to search for a task you want to perform.ÂÂ

Choose Help > Server Admin Help or Help > Workgroup Manager Help to browse ÂÂ
and search the help topics.

The onscreen help contains instructions taken from Server Administration and other 
advanced administration guides described later.

To see the most recent server help topics:
Make sure the server or administrator computer is connected to the Internet while mm

you’re getting help.

Help Viewer retrieves and caches the most recent server help topics from the Internet. 
When not connected to the Internet, Help Viewer displays cached help topics.

Document Road Map
Mac OS X Server v10.6 has a suite of guides that cover management of individual 
services. Each service may be depend other services for maximum utility. The road 
map below shows some related documentation that you may need in order to 
configure your desired service to your specifications. You can get these guides in PDF 
format from the Mac OS X Server documentation website:
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www.apple.com/server/resources/

Podcast Composer
Explains how to

create Podcast Producer
workflows using

Podcast Composer.

Podcast Producer
Administration

Describes advanced
options for setting up,

configuring, and managing
Podcast Producer service.

Podcast Producer
Workflow Tutorial
Walks you through

the process of creating
a complete Podcast
Producer workflow.

Podcast
Capture Help

Provides onscreen
instructions and answers

when you’re using
Podcast Capture to
record and submit

content for processing
by Podcast Producer.

Viewing PDF Guides Onscreen
While reading the PDF version of a guide onscreen, you can:

Show bookmarks to see the guide’s outline, and click a bookmark to jump to the ÂÂ
corresponding section.

Search for a word or phrase to see a list of places where it appears in the document. ÂÂ
Click a listed place to see the page where it occurs.

Click a cross-reference to jump to the referenced section. Click a web link to visit the ÂÂ
website in your browser.

Printing PDF Guides
If you want to print a guide, you can take these steps to save paper and ink:

Save ink or toner by not printing the cover page.ÂÂ

Save color ink on a color printer by looking in the panes of the Print dialog for an ÂÂ
option to print in grays or black and white.

http://www.apple.com/server/resources/
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Reduce the bulk of the printed document and save paper by printing more than ÂÂ
one page per sheet of paper. In the Print dialog, change Scale to 115% (155% 
for Getting Started). Then choose Layout from the untitled pop-up menu. If your 
printer supports two-sided (duplex) printing, select one of the Two-Sided options. 
Otherwise, choose 2 from the Pages per Sheet pop-up menu, and optionally choose 
Single Hairline from the Border menu. (If you’re using Mac OS X v10.4 or earlier, the 
Scale setting is in the Page Setup dialog and the Layout settings are in the Print 
dialog.)

You may want to enlarge the printed pages even if you don’t print double sided, 
because the PDF page size is smaller than standard printer paper. In the Print dialog or 
Page Setup dialog, try changing Scale to 115% (155% for Getting Started, which has CD-
size pages).

Getting Documentation Updates
Periodically, Apple posts revised help pages and new editions of guides. Some revised 
help pages update the latest editions of the guides.

To view new onscreen help topics for a server application, make sure your server or ÂÂ
administrator computer is connected to the Internet and click “Latest help topics” or 
“Staying current” in the main help page for the application.

To download the latest guides in PDF format, go to the Mac OS X Server ÂÂ
documentation website:

www.apple.com/server/resources/

An RSS feed listing the latest updates to Mac OS X Server documentation and ÂÂ
onscreen help is available. To view the feed use an RSS reader application, such as 
Safari or Mail:

feed://helposx.apple.com/rss/snowleopard/serverdocupdates.xml

Getting Additional Information
For more information, consult these resources:

ÂÂ Read Me documents—get important updates and special information. Look for them 
on the server discs.

ÂÂ Mac OS X Server website (www.apple.com/server/macosx/)—enter the gateway to 
extensive product and technology information.

ÂÂ Mac OS X Server Support website (www.apple.com/support/macosxserver/)—access 
hundreds of articles from Apple’s support organization.

ÂÂ Apple Discussions website (discussions.apple.com/)—share questions, knowledge, 
and advice with other administrators.

http://www.apple.com/server/resources/
feed://helposx.apple.com/rss/snowleopard/serverdocupdates.xml
http://www.apple.com/server/macosx/
http://www.apple.com/support/macosxserver/
http://discussions.apple.com/
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ÂÂ Apple Mailing Lists website (www.lists.apple.com/)—subscribe to mailing lists so you 
can communicate with other administrators using email.

ÂÂ Apple Training and Certification website (www.apple.com/training/)—hone 
your server administration skills with instructor-led or self-paced training, and 
differentiate yourself with certification.

http://www.lists.apple.com/
http://www.apple.com/training/
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Use this chapter to learn concepts about Podcast Composer 
and how you can use it to create Podcast Producer 
workflows.

Podcast Producer workflows are self-contained file bundles that contain all the 
information, code, and resources that Podcast Producer needs to produce podcasts.

Developing a workflow manually can be a challenging task for developers and 
nondevelopers alike because it involves editing XML files, using Podcast Producer 
command-line commands, and ensuring that all resources are included in the right 
place in the bundle. The more complicated the workflow is, the more time it takes to 
build.

Podcast Composer, an application that ships with Mac OS X Server, simplifies and 
speeds up the process of building workflows by providing you with a simple graphical 
user interface. All you do is provide information about the workflow, without writing 
XML code or worrying about where to store resources and credentials.

With Podcast Composer, creative individuals and administrators can easily develop 
workflows that can later be customized, if needed, by developers.

Podcast Composer builds highly optimized workflows that take advantage of the 
parallel processing capability offered by Xgrid.

How Podcast Composer Works
Podcast Composer groups the process of building a workflow into seven stages that 
step you through the process of creating a workflow:

1. Information You specify basic workflow information: workflow name, copyright text, 
and a brief description of the workflow.

1Podcast Composer Overview



Apple Confidential Beta Draft

	 Chapter 1    Podcast Composer Overview	 11

2. Import You tell the workflow what to expect as input: a single QuickTime movie, 
two QuickTime movies, or a set of documents that are compatible with Quick Look. 
The output of this stage is a single QuickTime movie. If the input to this stage is two 
movies, Podcast Composer produces a picture-in-picture movie. If the input to this 
stage is documents, Podcast Composer produces treats document pages as images 
and renders them into a movie with transitions between the images.

3. Edit You brand the podcast that the workflow generates by adding custom 
watermarks and introduction, title, and exit movies. The output of this stage is a master 
rebranded movie. Podcast Composer produces the highest quality movie with the best 
possible resolution based on the resolution of the input files. This master movie is a flat 
QuickTime media file used as a reference movie in the next stage.

4. Export You select the different types of encodings to be used for publishing your 
podcast. For example, you might want your podcast to be available in three flavors: 
iPhone/iPod, Apple TV, and AAC (audio-only).

5. Publish You determine how the podcast is published. For example, you can 
configure the Publish stage to publish the different versions of the podcast to the 
Podcast Library.

6. Notify You create the notifications that you want the workflow to send after the 
podcast is published. You can send notifications to users and administrators with 
instruction on how to access the podcast. You can also send notifications to services to 
let them know that new content is published to the Podcast Library.

7. Summary You verify your selections. If no more changes are required, you deploy the 
workflow to Podcast Producer server.

When working on a particular stage, Podcast Composer keeps the previous and next 
stages in view to provide context.

The workflow that you generate using Podcast Composer is a file bundle. A workflow 
bundle contains the code, resources, credentials, workflow description, and all the 
information needed to execute the workflow.

In the Export, Publish and Notify stages, you can’t have more than nine elements per 
stage.

Navigating the Podcast Composer Stages
Podcast Composer provides several ways to view and navigate stages.

Using the Arrow Keys
Use the Up and Down arrow keys to move from one stage to another.ÂÂ

Use the Right and Left arrow keys to move among items in a stage.ÂÂ
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Using the Commands in the Stages Menu
To move to a stage, choose Stage > ÂÂ stage name or use the Command-[stage 
number] shortcut. For example, to go to the Edit stage, choose Stages > Edit or press 
Command-3.

To move up or down the stages, use the Stages > Previous or Stages > Next ÂÂ
command.

To view all stages at once, choose Stages > Overview or press Command-Return. ÂÂ
To return to the normal view, use the same command. This command allows you to 
switch between normal and overview views. You can also double-click the header of 
a stage to run the Overview mode.

Obtaining Help
To access Podcast Composer onscreen help, use the Help menu.

To access context-sensitive help about a stage, click the Help button (?) at the bottom 
right of the active stage.

Creating a Workflow
This section describes how to create a workflow using Podcast Composer.

To create a workflow in Podcast Composer:
	 1	 Open Podcast Composer (in /Applications/Server/).

	 2	 Choose File > New.

	 3	 Choose File > Save.

	 4	 In the Save As dialog box, enter the name of the workflow bundle and specify where 
to store it.

The name that you enter in this field can be different from the name you specify in the 
Information stage.

	 5	 Go through stages 1 to 6 to configure your workflow. 

Remember to periodically save your workflow while working on it.

To configure basic workflow settings, see Chapter ÂÂ 2, “Configuring Basic Workflow 
Information.”

To specify the input source type, see Chapter ÂÂ 3, “Configuring the Import Stage.”

To brand your podcast, see Chapter ÂÂ 4, “Configuring the Edit Stage.”

To specify the output formats for your podcast, see Chapter ÂÂ 5, “Configuring the 
Export Stage.”

To specify destinations for your podcast, see Chapter ÂÂ 6, “Configuring the Publish 
Stage.”

	 12		  Chapter 1    Podcast Composer Overview
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To configure notifications announcing the publishing of your podcast, see ÂÂ
Chapter 7, “Configuring the Notify Stage.”

	 6	 Save your workflow (see “Saving a Workflow” on page 38).

	 7	 Verify your workflow (see “Verifying a Workflow” on page 39).

	 8	 Deploy your workflow (see “Deploying a Workflow” on page 40).

To extend your workflow, or to learn about advanced Podcast Composer topics, see 
Chapter 9, “Advanced Podcast Composer Topics.”
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Use this chapter to set the name, copyright, and description 
information of a workflow.

Every workflow defines a set of metadata or information about the workflow. Podcast 
Composer lets you define three fields that are referenced in Podcast Producer server: 
Workflow Name, Author, and Description.

Configuring Basic Workflow Information
In the first Podcast Composer stage, Information, you specify the following information 
or metadata:

Workflow Name—The name of the workflow. This is the name that appears in the ÂÂ
Workflow pane of the Podcast Producer service. It also appears in the Workflow 
drop-down menu in Podcast Capture. This name can be different from the name you 
give to the Workflow bundle you create with Podcast Composer.

Author—The name of the workflow’s author information for your workflow. When ÂÂ
building your workflow in Podcast Composer, you can configure the workflow 
settings to display the author information in the resulting podcast.

Description—A brief description of your workflow. The description you enter here ÂÂ
helps Podcast Producer administrators and Podcast Capture users understand what 
the workflow does.

When you create a workflow bundle with Podcast Composer, the Workflow Name, 
Copyright, and Description metadata is stored in the info.plist file inside the workflow’s 
bundle.

To set the workflow name, copyright, and description information:
	 1	 In Podcast Composer, go to the Information stage (choose Stages > Information or 

press Command-1).

	 2	 In the Workflow Name field, enter the name of the workflow as you want it to appear 
in Server Admin and Podcast Capture.

	 3	 In the Copyright field, enter the copyright information for your workflow.

2Configuring Basic Workflow 
Information
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	 4	 In the Description field, enter a brief description of your workflow.

	 5	 Choose File > Save.
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Use this chapter to learn how to specify the types of the 
input sources to the workflow in the Import stage of Podcast 
Composer.

In the Import stage, you select the input source of the content your workflow 
processes. Podcast Composer provides three choices:

Single Source—A single QuickTime movie as input to the workflow. The QuickTime ÂÂ
movie can be a video recording, a screen recording, or an audio-only recording.

Dual Source—Two QuickTime movies (with video tracks) as input to the workflow. ÂÂ
For this choice, you cannot use a source with only an audio track. For example, a 
video recording of a lecturer and a screen recording of the lecturer’s slides. The 
video recordings can come from a remote camera and a local screen, two remote 
cameras, or a local camera and local screen.

Documents—Documents that can be rendered by Quick Look. For example, PDF, ÂÂ
Keynote, Pages, Numbers, Word, PowerPoint, image, and video files.

The output of the Import stage is a single movie, which is also the input movie to the 
next stage, Edit.

Configuring Single Source
If you want the workflow to create a podcast from only one QuickTime movie, select 
and configure the Single Source option of the Import stage.

To configure the Single Source option of the Import stage in Podcast Composer:
	 1	 In Podcast Composer, go to the Import Stage (choose Stages > Import or press 

Command-2).

	 2	 Double-click Single Source, or move your mouse over the Single Source icon and click 
the Information button in the bottom-right corner of the icon.

If Single Source is selected, you can press Enter to display the Information dialog.

	 3	 From the Single Source Type pop-up menu, choose one of the following options to 
specify the type of recording Podcast Capture users can use with this workflow:

3Configuring the Import Stage
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Any—The input movie can be a video recording, a screen recording, or an audio-ÂÂ
only recording.

Video Device Only—The input movie is a video recording.ÂÂ

Screen Recorder Only—The input movie is a screen recording.ÂÂ

Audio Only—The input movie is an audio-only recording.ÂÂ

	 4	 If you want the workflow to automatically detect changes in the input movie and use 
this information to assign chapters in the generated podcast, select Automatic Chapter 
Generation.

In the case of a screen recording, the workflow inserts a chapter marker in the video 
when it detects a slide transition or when no changes occur in the video at a certain 
moment. This is useful when doing a screen recording or for any video that includes 
presentations.

The tool used by the workflow to add chapter markers detects stability in a movie by 
comparing frames and after the tool finds a stable sequence, it considers it a chapter. 
Then, when the sequence changes to another sequence, the tool consider that change 
a transition.

Chapter markers are recommended for screen recordings, but not for video and audio 
recordings. However, there are instances when adding these markers is useful, such 
as when the source video is for a screen recording captured from the VGA or DVI 
stream of a computer screen. Screen recording using Podcast Capture works only on a 
computer running Mac OS X v10.5 or later.

	 5	 Click Done.

	 6	 Choose File > Save.

Configuring Dual Source
If you want the workflow to create a podcast from two QuickTime movies, select and 
configure the Dual Source option of the Import stage. For example, a screen recording 
of a presentation and a video of the presenter.

Important:  It is recommended that you provide the audio of the entire recording in 
the video of the presenter and not within the screen recording.

To configure the Dual Source option of the Import stage in Podcast Composer:
	 1	 In Podcast Composer, go to the Import Stage (choose Stages > Import or press 

Command-2).

	 2	 Double-click Dual Source, or move your mouse over the Dual Source icon and click the 
Information button in the lower-right corner.

A dialog appears, displaying the settings that you can configure and a live preview box 
that reflects your selections.
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	 3	 From the Dual Source Composition pop-up menu, choose one of the following 
composition options to specify how the two input videos are going to be composed 
to create the final movie:

Keynote Presentation—This picture-in-picture composition displays the screen ÂÂ
recording movie in full screen and hides the second movie. After 15 seconds (by 
default) this composition minimizes the screen recording movie, moves it to the 
right, and displays the second movie in the bottom-left corner of the screen. Finally, 
after 15 seconds (by default) the composition brings back the screen recording 
movie into full screen and hides the second movie. This process repeats for the 
duration of the movie.

Overlay—This picture-in-picture composition displays the screen recording movie ÂÂ
in full screen and overlays the second movie in the bottom-right corner of the 
screen. Then, in response to conditions in the screen recording (for example, a slide 
doesn’t change for more than 20 seconds) the location of the overlay is switched, if 
transition detection is enabled. If transition detection is not enabled, both movies 
remain in their original positions.

Overlay with Fade—This composition is similar to the Overlay composition, but ÂÂ
instead of keeping the second movie in view all the time, this composition fades the 
movie in and out at certain intervals (10 seconds by default).

Theater—This composition is similar to the Overlay composition, except that you ÂÂ
always have a full view of the screen recording movie. This option is ideal if you 
don’t want any part of the screen recording to be covered by the other movie.

	 4	 If you want Podcast Composer to automatically detect transitions in the screen 
recording movie, select Automatic Transitions.

With this option enabled, Podcast Composer can detect slide transitions in the movie 
and use this information to determine when to switch movies in the composition.

If you choose not to automatically detect transitions, there will be no transition. The 
selected dual source composition remains static. Both movies remain in their original 
positions.

	 5	 If you want Podcast Composer to automatically detect changes in the input movies 
and use this information to assign chapters in the generated podcast, select Automatic 
Chapter Generation.

For example, you might want chapters in the podcast to mark each transition to a new 
slide.

In the case of a screen recording, the workflow inserts a chapter marker in the video 
when it detects a slide transition or when no changes occur in the video for a certain 
moment. This is useful when doing a screen recording or for any video that includes 
presentations.

	 18		  Chapter 3    Configuring the Import Stage
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The tool used by the workflow to add chapter markers detects stability in a movie by 
comparing frames. When the tool finds a stable sequence, it considers it a chapter. 
Then, when the sequence changes to another sequence, the tool consider that change 
a transition.

Chapter markers are recommended for screen recordings, but not for video and audio 
recordings. However, there are instances when adding these markers is useful, such 
as when the source video is for a screen recording captured from the VGA or DVI 
stream of a computer screen. Screen recording using Podcast Capture works only on a 
computer running Mac OS X v10.5 or later.

	 6	 Click Done.

	 7	 Choose File > Save.

Configuring Documents
If you want the workflow to create a podcast from documents, select and configure 
the Documents option of the Import stage. Podcast Composer treats the pages of 
these documents as images. It combines all pages of all documents into one slide 
presentation and generates a QuickTime video of the presentation.

For example, if your input is a PDF document and a Word document, Podcast 
Composer treats each page in these documents as an image. Then, Podcast Composer 
assembles these images into one presentation and uses the settings you specify for 
the Documents option to generate a QuickTime movie of a slide show of the images.

If a document isn’t in landscape mode, displaying a page in full for each slide results in 
text that might be hard to read because the page can’t fill the entire width of the slide. 
To solve this problem, Podcast Composer slices each document page in half. The upper 
half image of a page appears on one slide and the bottom half image appears on 
the following slide. In addition, Podcast Composer adds a transition between the two 
slides to provide a scrolling effect.

As input for the Documents option, you can use PDF, Word, PowerPoint, Pages, 
Keynote, image, and movie documents, which can be rendered by Quick Looks.

The documents are concatenated and added to the movie according to their alpha-
numeric order.

To configure the Documents option of the Import stage in Podcast Composer:
	 1	 In Podcast Composer, go to the Import Stage (choose Stages > Import or press 

Command-2).

	 2	 Double-click Documents, or move your mouse over the Documents icon and click the 
Information button in the lower-right corner.
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A dialog appears, displaying the settings that you can configure and a live preview 
video that reflects your selections.

	 3	 In the Image Duration field, enter the number of seconds that each slide is displayed.

	 4	 To specify a transition effect:

From the Transition Effect pop-up menu, choose an effect.ÂÂ

From the Direction pop-up menu, choose the direction of the effect (if applicable).ÂÂ

In the Duration field, specify the duration of the transition in seconds.ÂÂ

	 5	 If you want Podcast Composer to automatically detect changes in the input movies 
and use this information to assign chapters in the generated podcast, select Automatic 
Chapter Generation.

For example, you might want chapters in the podcast to mark each transition to a new 
slide.

In the case of documents, every page is considered a chapter. The workflow uses Quick 
Look to extract a title from these pages to assign a meaningful title to chapters.

	 6	 Click Done.

	 7	 Choose File > Save.

	 20		  Chapter 3    Configuring the Import Stage
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Use this chapter to configure the introduction, title, and exit 
movies and how to add a watermark to your podcast.

In the Edit stage of Podcast Composer, you can brand your podcast by adding any of 
the following items:

Introduction movie—For example, you might want your podcasts to start with a ÂÂ
10-second movie that displays you organization’s logo.

Title movie—For example, you might want your podcast to have a title screen that ÂÂ
displays information extracted from the workflow’s metadata, such as title, author, 
copyright, and description.

Watermark—For example, you might want the podcast to display the logo of your ÂÂ
organization as a watermark.

Exit movie—For example, you might want your podcasts to end with the same ÂÂ
movie, giving credit to your organization.

You can also add transitions between these items.

In this stage, Podcast Composer places the branding items and the input movie in a 
timeline from left to right, in the following default order:

Introduction movie (optional) ÂÂ

Transition (optional)ÂÂ

Title movie (optional)ÂÂ

Transition (optional)ÂÂ

Input movieÂÂ

Transition (optional)ÂÂ

Exit movie (optional)ÂÂ

You can skim through the video clip in the timeline to preview video contents.

4Configuring the Edit Stage
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In the Edit stage, you can also:

Use the remove (–) button or press Backspace to remove an optional item. Use ÂÂ
the Add (+) button to add an item. To delete all optional items, press Command-
Backspace.

Use the Theme button to select a theme for the podcast. This button is disabled ÂÂ
by default because Podcast Composer ships with one theme. However, if you add 
custom themes, this button is enabled.

Use the Preview button to preview the movie that will be generated by the Edit ÂÂ
stage.

Adding and Configuring an Introduction Movie
By default, the film strip in the Edit stage includes an introduction movie. If an 
introduction movie isn’t present, click the add (+) button and select Introduction to 
add the movie.

To delete the Introduction icon from film strip, select the icon and press Backspace.

To configure the introduction movie:
	 1	 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

	 2	 Double-click the icon of the introduction movie.

	 3	 From the Introduction Movie pop-up menu, choose a default introduction movie that 
comes with Podcast Composer.

To select a custom movie, select Choose, browse for the movie, select it, and click 
Open. You can also drag the movie onto the preview movie in the pop-up menu.

You can also drag a movie directly onto the icon of the introduction movie without 
opening the pop-up menu.

	 4	 Click Done.

	 5	 Choose File > Save.

Adding a Title Movie
By default, the film strip in the Edit stage includes a title movie. If it isn’t present, click 
the add (+) button and select Title to add the movie.

To configure the title movie:
	 1	 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

	 2	 Double-click the icon of the title movie.

	 3	 From the Bumper Title pop-up menu, choose one of the default styles.
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	 4	 From the Logo Media, if enabled, choose a default style. You can also select Choose to 
add your own logo, or drag the logo onto the preview video.

	 5	 Select the items to include in the title video:

TitleÂÂ

DateÂÂ

CopyrightÂÂ

DescriptionÂÂ

AuthorÂÂ

OrganizationÂÂ

	 6	 Click Done.

	 7	 Choose File > Save.

Adding a Watermark and an Introduction Overlay
You can use the Edit stage to add a watermark and an introduction overlay to the 
input movie. 

A watermark can be an image, a movie, or a Quartz Composition.

An introduction overlay is a title that appears on top of the movie for a specified 
amount of time at the beginning of the movie.

To add a watermark to the input movie:
	 1	 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

	 2	 Double-click the icon of the input movie.

	 3	 From the Watermark pop-up menu, choose a default watermark style.

To use a custom watermark, select Choose and select the watermark. You can also drag 
the watermark onto the preview movie.

You can also drag a watermark onto the watermark and introduction overlay icon 
without opening the pop-up menu.

	 4	 To specify the opacity of the watermark, move the Opacity slider to the left (more 
transparent) or to the right (less transparent).

	 5	 To specify the size of the watermark, move the Sizing slider to the left (smaller) or to 
the right (bigger).

	 6	 To specify the position of the watermark, choose an option from the Position pop-up 
menu.

	 7	 To add an introduction overlay over the input movie and under the watermark, choose 
an overlay style from the Introduction Overlay pop-up menu. 



Apple Confidential Beta Draft

Select the information to display in the overlay by selecting checkboxes. Depending 
on the overlay style you choose, some of the check boxes might be disabled.

You can also drag a movie onto the watermark and introduction overlay icon without 
opening the pop-up menu.

	 8	 Click Done.

	 9	 Choose File > Save.

Adding and Configuring an Exit Movie
By default, the film strip in the Edit stage includes an exit movie. If an exit movie isn’t 
present, click the Add (+) button and select Exit to add the movie.

To configure the exit movie:
	 1	 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

	 2	 Double-click the icon of the exit movie.

	 3	 From the Exit Movie pop-up menu, choose a default exit movie that comes with 
Podcast Composer.

To select a custom movie, select Choose from the pop-up menu, browse for the movie, 
select it, and click Open. You can also add an exit movie by dragging the movie onto 
the live preview box.

	 4	 Click Done.

	 5	 Choose File > Save.

Configuring Transitions
You can configure transitions between movies in the Edit stage.

To configure transitions:
	 1	 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

	 2	 Double-click the icon of the transition.

	 3	 Choose a transition from the Transition pop-up menu.

If you don’t need a transition, choose None.

	 4	 If the Direction pop-up menu is enabled, choose the direction of the transition.

	 5	 If the Duration field is enabled, enter the duration of the transition in seconds.

	 6	 Click Done.

	 7	 Choose File > Save.
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Previewing the Podcast
The Edit stage provides a live preview window where you can preview the QuickTime 
movie that is generated by the Edit stage. While the window is open, changes you 
make in the Edit stage are reflected in the live preview.

To open the live preview window:
	 1	 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

	 2	 Click the Preview button.

To display a bigger live preview window, alt-click the Preview button.
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Use this chapter to learn how to specify the encoding 
formats to use for publishing your podcast.

In the Export stage of Podcast Composer, you select output formats for your podcast. 
For example, to optimize your podcast for iPhones and Apple TV, you can select those 
two formats in the Export stage. For every format you select in the Export stage, 
Podcast Composer creates a corresponding task in the workflow.

Podcast Composer supports the following QuickTime encoding formats:

Apple TVÂÂ

Video: H.264 Video, 1280 x 720, 5 Mbps, 30 fps

Audio: AAC-LC Music, Stereo, 128 kbps, 44.1 kHz

AudioÂÂ

Video: None

Audio: AAC-LC Music, Stereo, 128 kbps, 44.1 kHz

iPod/iPhoneÂÂ

Video: H.264 Video, 640 x 480, 1.5 Mbps, 30 fps

Audio: AAC-LC Music, Stereo, 128 kbps, 44.1 kHz

MobileÂÂ

Video: H.264 Video, 176 x 144, 56 kbps, 15 fps

Audio: AAC-LC Music, Mono, 24 kbps, 16 kHz

In addition, Podcast Composer lets you specify custom encoding formats that you 
create with the Compressor application, which must be installed on the computer 
running Podcast Composer and launched at least once before you can use it with 
Podcast Composer. The Compressor application should also be installed on Xgrid 
nodes used by the workflow.

Compressor is a post-production application. It ships with Final Cut Studio.

5Configuring the Export Stage
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Note:  Only very few default Compressor encodings are playable on an iPod or iPhone. 
Before deploying a custom composition, be sure it fits the target device requirements.

Adding QuickTime Encoding Formats
You can add up to four QuickTime encoding formats in the Export stage.

To add a QuickTime encoding format to the Export stage:
	 1	 In Podcast Composer, go to the Export stage (choose Stages > Export or press 

Command-4).

	 2	 Click the Add (+) button.

If the Compressor plug-in is installed, a pop-up menu appears.

	 3	 Choose QuickTime.

A QuickTime encoder is added to the Export stage and a dialog box appears.

	 4	 From the QuickTime Encoder pop-up menu, choose the encoder you want to use.

	 5	 Click Done.

	 6	 Choose File > Save.

Adding Compressor Formats
Podcast Composer supports encoding formats that you create using the Compressor 
application. However, you must first install Compressor on your computer. For more 
information on how to install Compressor, see the Compressor documentation.

To add Compressor encoding formats to the Export stage:
	 1	 In Podcast Composer, go to the Export stage (choose Stages > Export or press 

Command-4).

	 2	 Click the Add (+) button.

	 3	 From the pop-up menu, choose Compressor.

A Compressor encoder is added to the Export stage and a dialog appears.

	 4	 From the Compressor Encoder pop-up menu, choose the encoder you want to use.

This menu shows the custom encodings you created using Compressor.

	 5	 To use the Apple Qmaster distributed processing system to speed up the encoding 
process, enter the required information.

Apple Qmaster speeds up encoding by dividing the total number of frames in a job 
into smaller segments. Each of the processing computers then works on a different 
segment. Because the nodes are working in parallel, the job is finished sooner than it 
would be on a single computer.
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For more information about the Apple Qmaster distributed processing system, see 
Apple Qmaster 2 and Compressor 2 Distributed Processing Setup.

	 6	 Click Done.

	 7	 Choose File > Save.

	 28		  Chapter 5    Configuring the Export Stage



Apple Confidential Beta Draft

		�  29

Use this chapter to specify and configure the publishing 
destinations of your podcast.

In the Publish stage, you specify a destination for each podcast export format you 
added in the Export stage.

The Publish stage supports the following content destinations:

Podcast LibraryÂÂ

Apple Wiki (optional)ÂÂ

File Transfer (optional)ÂÂ

Final Cut Server (optional)ÂÂ

Folder (optional)ÂÂ

Workflow (optional)ÂÂ

Sending Content to the Podcast Library
The Podcast Library is where you store content. The Podcast Library publishes the 
content through Atom or RSS feeds, and keeps track of your content automatically.

To add the Podcast Library to the Publish stage:
	 1	 In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

By default, the Podcast Library is added to the Publish stage.

	 2	 If the Podcast Library element is present, double-click it; if not, click the Add (+) button 
and choose Podcast Library.

A dialog appears.

	 3	 Under “Publish media files to Podcast Library,” select the media file to publish to the 
Podcast Library:

Original Sources—Select this option to archive the original source files used to ÂÂ
create your podcast.

6Configuring the Publish Stage
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Preview Files—Select this option to archive the preview files generated by Podcast ÂÂ
Composer.

Edited Master—Select this option to archive the edited master file from which ÂÂ
encoded content is generated. This is a high-quality flat movie that you may need 
later if you want to re-encode the podcast using a different format.

Generated Media Files—Select this option to publish the media files generated by ÂÂ
the workflow.

	 4	 (Optional) In the Tags field, add tags, separated by commas, to make it easier to find 
your content.

The Podcast Library adds these tags to every published media file. In addition, the 
Podcast Library creates a feed for every tag.

Tags are a good and easy way to create multiple feeds for the same workflows. For 
example, you might want to have some workflows be accessible based on the year of 
the class and the department’s name.

	 5	 Click Done.

	 6	 Choose File > Save.

Sending Content to an Apple Wiki Server
One way to publish podcasts is to post your podcast on an Apple blog. You can add 
one or more Apple blog destinations.

To post a podcast to an Apple wiki:
	 1	 In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

	 2	 Click the Add (+) button and choose Apple Wiki.

A dialog appears.

	 3	 From the pop-up menu, choose the podcast format for posting to the blog.

	 4	 In the Server field, enter the address of the blog.

	 5	 If the wiki requires Secure Socket Layer protection, select Use Secure Socket Layer 
(SSL).

	 6	 In the User Name and Password fields, enter the administrator credentials to access the 
blog.

	 7	 To specify the destination of the podcast in the blog, select one of the following 
options:

Submitting User Blog—The blog of the user who submitted the podcast.ÂÂ

Custom User Blog—The blog of the user specified in the field at the right.ÂÂ

Custom Group Blog—The blog of the group specified in the field at the right.ÂÂ
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	 8	 Click Done.

	 9	 Choose File > Save.

Sending Content Using File Transfer Protocols
Podcast Composer lets you send content to backup file systems using these file 
transfer protocols:

FTPÂÂ

FTPSÂÂ

SFTPÂÂ

WebDavÂÂ

WebDavsÂÂ

You can add one or more File Transfer destinations.

To send a podcast to a backup file system:
	 1	 In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

	 2	 Click the Add (+) button and choose File Transfer.

A dialog appears.

	 3	 From the pop-up menu, choose the podcast format for backing up to the file system.

	 4	 From the Protocol pop-up menu, choose the file transfer protocol to use.

	 5	 In the Server field, enter the address of the server to send the files to.

	 6	 In the Path field, enter the path for where the podcast should be stored.

	 7	 In the User Name and Password fields, enter the administrator credentials to access the 
file system.

	 8	 Click Done.

	 9	 Choose File > Save.

Sending Content to the Watch Folder of Final Cut Server
In the Publish stage of Podcast Composer, you can choose to send content to the 
Watch folder of Final Cut Server for further processing.

You can add one or more Final Cut Server destinations.

To submit content to Final Cut Server:
	 1	  In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

	 2	 Click the Add (+) button and choose Final Cut Server.
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A dialog appears.

	 3	 From the pop-up menu, choose the podcast format for sending to Final Cut Server.

	 4	  In the “Path to Final Cut Server Watch Folder” field, enter the path to the Watch folder.

	 5	 Click Done.

	 6	 Choose File > Save.

Sending Content to a Shared Folder
The Publish stage of Podcast Composer allows you send content to a shared folder. 
You can add one or more shared folder destinations.

To send content to a shared folder:
	 1	  In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

	 2	 Click the Add (+) button and choose Folder.

A dialog appears.

	 3	 From the pop-up menu, choose the podcast format for sending to the shared folder.

	 4	 In the “Path to Shared Folder” field, enter the path to the shared folder.

	 5	 To use day folders, select “Use day folders.”

This option creates an intermediate folder for every day of the year to store all content 
published on that day. 

	 6	 Click Done.

	 7	 Choose File > Save.

Sending Content to a Workflow
You might want to send your podcast to another custom workflow or workflow chain, 
to perform additional tasks that you can’t configure in Podcast Composer.

You can add one or more workflow destinations. 

To send content to a workflow:
	 1	  In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

	 2	 Click the Add (+) button and choose Workflow.

A dialog appears.

	 3	 Click the Add (+) button to add media files to the list of media files to submit to 
Podcast Producer.
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	 4	 In the Workflow field, enter the name of the workflow that Podcast Producer will use to 
process the submitted content.

	 5	 In the User Name and Password fields, enter the user credentials needed to submit the 
job to Podcast Producer.

	 6	 Click Done.

	 7	 Choose File > Save.
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Use this chapter to learn how to create notifications, which 
Podcast Producer sends to announce published podcasts.

In the Notify stage of Podcast Composer, you add and configure notifications to be 
sent to users announcing the publishing of podcasts.

You can add the following types of notifications:

EmailÂÂ

iChatÂÂ

iTunes Podcast DirectoryÂÂ

iTunes UÂÂ

ServiceÂÂ

Adding Email Notifications
In the Notify stage, you can add one or more email notifications.

To add an Email notification:
	 1	 In Podcast Composer, go to the Notify stage (choose Stages > Notify, or press 

Command-6).

	 2	 Click the Add (+) button and choose Email.

A dialog appears.

	 3	 Select the mail recipients:

Podcast Producer Administrator—Select this option to send an email notification to ÂÂ
the administrator of the Podcast Producer server.

Submitting User—Select this option to send an email notification to the user who ÂÂ
submitted the workflow.

Others—Select this option and enter the email addresses (separated by commas) of ÂÂ
the notification recipients.

	 4	 In the Email Address field, enter the address of the person sending the email.

7Configuring the Notify Stage
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	 5	 In the Server Address field, enter the address of the server used for sending the email.

	 6	 If the email requires Secure Socket Layer protection, select Use Secure Socket Layer 
(SSL).

	 7	 From the Authentication menu, choose the authentication type.

	 8	 In the User Name and Password fields, enter the administrator credentials to send the 
email.

	 9	 Click Done.

	 10	 Choose File > Save.

Adding iChat Notifications
In the Notify stage, you can add iChat notifications.

For iChat notifications to work, you need access to an iChat server running on Mac OS 
X Server v10.6. If not, you must set up your own iChat server. Notifications fail if sent 
through an iChat server running on Mac OS X Server v10.5 or earlier.

However, if you need to send the notifications through an iChat server running on 
v10.5, you can set up an iChat server on a computer running v10.6 and federate it to 
an iChat server running on a computer with v10.5. The notifications first go through 
the iChat server running on the v10.6 computer and then through the iChat server 
running on the v10.5 server.

The iChat server doesn't need to run on the Podcast Producer server.

For more information about setting up an iChat server, see iChat Service Administration.

To add an iChat notification:
	 1	  In Podcast Composer, go to the Notify stage (choose Stages > Notify, or press 

Command-6).

	 2	 Click the Add (+) button and choose iChat.

A dialog appears.

	 3	 Select the iChat recipients:

Podcast Producer administrator—Select this option to send an iChat notification ÂÂ
message to the administrator of the Podcast Producer server.

Submitting user—Select this option to send an iChat notification message to the ÂÂ
user who submitted the workflow.

Others—Select this option and enter the iChat addresses (separated by commas) of ÂÂ
the notification recipients.

	 4	 In the Jabber ID and Password fields, enter the administrator credentials to send the 
iChat message.
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iChat notifications work with Jabber accounts only.

	 5	 In the iChat message field, enter the text of the notification message to be sent via 
iChat.

In the message, you can add $$KEY$$ variables, which are replaced by Podcast 
Producer.

	 6	 To add publishing information to the iChat message, select “Display additional 
information.”

	 7	 Click Done.

	 8	 Choose File > Save.

Adding iTunes Podcast Directory Notifications
In the Notify stage, you can add only one iTunes Podcast Directory notification. For 
this notification to work, you must first register your feeds with iTunes. When this 
notification is sent to iTunes, the iTunes podcast repository syncs with your Podcast 
Library as soon as possible to reflect all changes. This action is asynchronous.

For more information about Podcast Library, see Podcast Producer Administration.

To add an iTunes Podcast Directory notification:
	 1	  In Podcast Composer, go to the Notify stage (choose Stages > Notify or press 

Command-6).

	 2	 Click the Add (+) button and choose iTunes Podcast Directory.

	 3	 Choose File > Save.

Adding iTunes U Notifications
In the Notify stage, you can add iTunes U notifications. You specify the address of the 
iTunes U site to send the notification to. Upon receiving the notification, iTunes U syncs 
with the feeds you registered with it as soon as possible. This action is asynchronous.

Before sending iTunes U notifications, you must register feeds with the iTunes U site.

To add an iTunes U notification:
	 1	  In Podcast Composer, go to the Notify stage (choose Stages > Notify or press 

Command-6).

	 2	 Click the Add (+) button and choose iTunes U.

A dialog appears.

	 3	 Enter the address of the iTunes U site.

	 4	 Click Done.
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	 5	 Choose File > Save.

Adding Third-Party Service Notifications
In the Notify stage, you can add Service notifications. You specify the address of the 
service to ping.

To add a Service notification:
	 1	  In Podcast Composer, go to the Notify stage (choose Stages > Notify or press 

Command-6).

	 2	 Click the Add (+) button and choose Service.

A dialog appears.

	 3	 Enter the address of the service.

	 4	 Click Done.

	 5	 Choose File > Save.
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Use this chapter to learn how to use Podcast Composer to 
verify, deploy, and manage your workflow.

Viewing a Summary of the Workflow
The last stage in Podcast Composer provides a bird's-eye view of your workflow by 
listing the icons of the tasks you’ve defined in your workflow. Use this stage to make 
sure your workflow is complete.

To see a summary of your workflow:
In Podcast Composer, go to the Summary stage (choose Stages > Summary or press mm

Command-7).

Saving a Workflow
To save a workflow in Podcast Composer, use the Save or Save As command from the 
File menu. You can also use the Save button in the Summary stage.

When you save a workflow, Podcast Composer generates a workflow bundle that 
contains all information and resources needed to process the workflow. This includes 
images, movies, presets, templates, tools, and compositions used by the workflow.

The workflow bundle also includes workflow metadata, password information, and the 
XML code that defines the workflow. The bundle also contains your credentials and the 
Xgrid job template the defines the tasks to execute and which tasks can be executed 
in parallel.

To save a new workflow:
	 1	 Choose File > Save (Command-S) or press the Save button in the Summary stage.

	 2	 In the Save As dialog, enter the name of the workflow bundle and specify where to 
store it.

8Managing Workflows



Apple Confidential Beta Draft

	 Chapter 8    Managing Workflows	 39

The name that you enter in this field can be different than the name you specified in 
the Information stage.

	 3	 Click Save.

To save changes to an existing workflow bundle, choose File > Save (Command-S) or 
press the Save button in the Summary stage.

To change the name of a workflow bundle, choose File > Save As (Command-Shift-S).

	 4	 In the Save As dialog, enter the new name of the workflow bundle.

Note:  A workflow can be saved even if not complete and not correct.

Using the Workflow Inspector
The Workflow Inspector in Podcast Composer lets you:

Specify the poster image for the podcast. This is the image associated with the ÂÂ
published podcast. If you don’t specify a poster image, Podcast Composer extracts a 
poster image from a frame that’s about one third of the way into the presentation.

View workflow statistics. The inspector displays the number of tasks in the workflow ÂÂ
and the maximum number of tasks that can be run in parallel.

Add notes about the workflow to the Workflow Notes field. These notes are stored ÂÂ
as metadata in the info.plist file at the root level of the workflow bundle.

To open the Workflow Inspector:
	 1	 In Podcast Composer, choose Window > Workflow Inspector.

	 2	 To set the workflow’s poster image, drag an image onto the Episode Poster Image field.

	 3	 To add notes about the workflow, enter the text in the Workflow Notes field.

Verifying a Workflow
Before deploying a completed workflow, it is good practice to verify the workflow, 
even though Podcast Composer verifies it before deploying it. By verifying the 
workflow, you can deploy it at a moment’s notice.

To verify a workflow in Podcast Composer:
	 1	 Choose File > Verify Workflow (Command-Y).

If the workflow isn’t configured correctly, a message appears describing the problem 
with the first workflow element that has missing settings. Podcast Composer displays a 
red arrow pointing to the element in question.

	 2	 If an error message appears:

	 a	 Click OK to dismiss the dialog.

	 b	 Fix the problem.
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	 c	 Verify the workflow again.

You might need to repeat these steps several times until the workflow passes 
verification.

	 3	 When the workflow is configured correctly and a message appears indicating 
successful workflow configuration, click OK.

Deploying a Workflow
When you finish building a workflow, you can use Podcast Composer to upload 
the workflow bundle to a Podcast Producer server. Podcast Producer makes the 
workflow available to Podcast Capture clients, as determined by the Podcast Producer 
administrator.

To deploy a workflow to a Podcast Producer server:
	 1	 In Podcast Composer, choose File > Deploy to Server (Command-U) or press the 

Deploy button on the Summary stage.

If your workflow is incomplete, a dialog appears describing the problem with the first 
incomplete setting in the workflow. Podcast Composer displays a red arrow pointing 
to the element that has the incomplete setting.

	 2	 If a dialog appears indicating that the workflow is incomplete, click the OK button to 
dismiss the dialog, fix the problem, and then try to deploy the workflow again.

You might need to repeat the process several times until the workflow passes 
verification.

	 3	 In the Server field of the Deploy dialog, enter the address of the Podcast Producer 
server or choose a server from the pop-up menu.

	 4	 Click Deploy.

	 5	 In the Name and Password fields, enter the administrator username and password 
assigned to you by the Podcast Producer administrator.

	 6	 Click Deploy again.

A dialog box appears indicating that the workflow was successfully uploaded to the 
Podcast Producer server.

Opening a Workflow Remotely
If you need to make changes to a workflow residing on a Podcast Producer server, use 
the File > Open Remote command in Podcast Composer.

To open a workflow remotely in Podcast Composer:
	 1	 Choose File > Open Remote (Command-Shift-O).
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	 2	 In the Server field of the Workflow Browser window, enter the address of the Podcast 
Producer server and then click Connect.

	 3	 In the Name and Password fields, enter the user name and password assigned to you 
by the Podcast Producer administrator.

	 4	 Click Connect again.

	 5	 Choose the workflow you want to edit from the Workflow list.
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Use this chapter to perform advanced Podcast Composer 
tasks such as customizing email templates and Quartz 
Composer compositions.

Extending Podcast Composer Workflows
Podcast Composer helps you quickly generate self-contained workflows that are ready 
for deployment. However, you might want to extend your workflow in a way that isn’t 
possible in Podcast Composer.

To extend your workflow, you can configure it in the Publish stage of Podcast 
Composer to send the output of the workflow to another workflow that you manually 
created. The second workflow adds your custom tasks to the workflow for execution.

Alternatively, you can take the workflow generated by Podcast Composer and extend 
it manually.

Note:  If you create a workflow using Podcast Composer and then manually extend the 
workflow, you can’t edit it again in Podcast Composer.

Selecting a Theme for the Podcast
Themes provide a consistent look and feel to your podcast, especially if your podcast 
consists of movies created by different people.

To select a theme for your podcast:
	 1	 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

	 2	 Click the Theme button in the Edit stage of Podcast Composer.

	 3	 Choose a theme from the pop-up menu.

A dialog appears prompting you to confirm that changing the theme modifies your 
current settings in the Edit stage.

9Advanced Podcast Composer 
Topics
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	 4	 Click Yes to change the theme; otherwise, click No.

	 5	 Choose File > Save.

Customizing Podcast Composer Themes
Podcast Composer ships with only one theme bundle (Apple Podcast.pwt). This theme 
is in /Applications/Server/Podcast Composer/Contents/Resources/Materials/Themes/.

To create themes, copy the default theme (Apple Podcast.pwt), rename the copy, and 
customize it as needed.

To create a custom theme:
	 1	 Copy the default theme to the following folder:

~/Library/Application Support/Podcast Composer/Resources/Themes/

	 2	 Rename the theme bundle.

	 3	 Update the Info.plist file inside the bundle (Contents/Info.plist). 

	 4	 Change the value of the CFBundleIdentifier key by replacing the name of the old 
theme with the new name.

For example, com.apple.PodcastProducer.theme.MyTheme.

	 5	 Change the values of the localized Info.plist keys.

For example, to change the values of the English strings, open Contents/Resources/
en.lproj/InfoPlist.strings and change the Copyright, Name, and Description strings to 
reflect the attributes of the new theme.

	 6	 Edit the Contents/Resources/theme.plist file as needed.

	 7	 Edit the Contents/version.plist file as needed.

Creating Quartz Composer Compositions
You can customize Quartz Composer compositions that ship with Podcast Producer or 
you can create your own compositions. However, you must have strong familiarity with 
Apple’s Quartz Composer, the application that lets you create Quartz compositions.

The default Quartz Composer compositions that ship with Podcast Producer are in the 
following folder:

/Applications/Server/Podcast Composer/Contents/Resources/Materials/Compositions/

This folder contains the following folders:

DualSourceÂÂ
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This folder stores the dual source transitions, which you can access in the Edit stage 
of Podcast Composer. For example, the Keynote.pqz bundle represents the Keynote 
composition.

TitlesÂÂ

This folder contains two folders:

BumperÂÂ

This folder contains the bumper title composition bundles.

OverlayÂÂ

This folder contains the overlay title composition bundles.

TransitionsÂÂ

This folder contains the transition bundles.

To customize Quartz Composer compositions or create new ones, you must install 
Quartz Composer on your computer. Quartz Composer is included with the Mac OS X 
developer tools.

To customize Quartz Composer compositions:
	 1	 Copy the Quartz Composer composition you want to edit to the relevant folder inside 

the following folder:

~/Library/Application Support/Podcast Composer/Resources/Compositions/

	 2	 Rename the Quartz Composer composition.

The name of the Quartz Composer composition must end with .pqz.

	 3	 Locate the Info.plist file inside the Quartz Composer composition bundle (Contents/
Info.plist).

	 4	 Open the Info.plist file.

	 5	 Change the value of the CFBundleIdentifier key by replacing the name of the old 
Quartz Composer composition with the new name.

For example, if you copied a dual source composition and named it C2.pqz, the value 
of the CFBundleIdentifier key should be com.apple.PodcastProducer.composition.
dualsource.C2.

	 6	 Change the values of the localized Info.plist keys.

For example, to change the values of the English strings, open Contents/Resources/
en.lproj/InfoPlist.strings and change the Copyright, Name, and Description strings to 
reflect the properties of the new composition.

	 7	 Save Info.plist.

	 8	 Replace the Preview.mov file (Contents/Resources/Preview.mov) with a new preview 
movie.
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	 9	 Locate the Quartz Composer file (ends with .qtz), which defines the composition.

For example, Contents/Resources/DualSource.qtz.

	 10	 Change the name of the Quartz Composer file to the new name.

	 11	 Open the Quartz Composer file using Quartz Composer, customize it as needed, and 
save your changes.

You can also change the Threshold key in the Info.plist file for dual source 
compositions. This key defines the length of time the video has to stay static before a 
transition is triggered.

The default values of the Threshold key are:

Overlay composition: 20 secondsÂÂ

Keynote composition: 15 secondsÂÂ

Overlay with Fade composition: 10 secondsÂÂ

Theater composition: 20 secondsÂÂ

Making Custom Quartz Composer Compositions Available to 
All Workflows
You can make Quartz Composer compositions available to all workflows in Podcast 
Composer by adding the compositions to the ~/Library/Application Support/Podcast 
Composer/Resources/Compositions/ folder.

To make Quartz Composer compositions available to all workflows in Podcast 
Composer:

	 1	 If Podcast Composer is open, close it.

	 2	 To add dual source Quartz Composer compositions, copy the composition bundles to 
the following folder:

~/Library/Application Support/Podcast Composer/Resources/Compositions/
DualSources/

	 3	 To add bumper title Quartz Composer compositions, copy the composition bundles to 
the following folder:

~/Library/Application Support/Podcast Composer/Resources/Compositions/Titles/
Bumper/

	 4	 To add overlay title Quartz Composer compositions, copy the composition bundles to 
the following folder:

~/Library/Application Support/Podcast Composer/Resources/Compositions/Titles/
Overlay/
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	 5	 To add transition Quartz Composer compositions, copy the composition bundles to 
the following folder:

~/Library/Application Support/Podcast Composer/Resources/Compositions/
Transitions/

	 6	 Start Podcast Composer.

	 7	 Verify that you can see the compositions in Podcast Composer.

Making Custom Introduction Movies Available to All 
Workflows
You can make introduction and exit movies available to all workflows in Podcast 
Composer by adding the movies to the relevant folder inside the ~/Library/Application 
Support/Podcast Composer/Resources/ folder.

To make introduction and exit movies available to all workflows in Podcast 
Composer:

	 1	 If Podcast Composer is open, close it.

	 2	 To add introduction movies, copy them to the following folder:

~/Library/Application Support/Podcast Composer/Resources/Movies/Introduction/

	 3	 To add exit movies, copy them to the following folder:

~/Library/Application Support/Podcast Composer/Resources/Movies/Exit/

	 4	 Start Podcast Composer.

	 5	 If you added introduction movies, go to the Edit stage and verify that you see the 
names of these movies in the "Introduction movie” pop-up menu of the introduction 
movie dialog.

	 6	 If you added exit movies, go to the Edit stage and verify that you see the names of 
these movies in the “Exit movie” pop-up menu of the introduction movie dialog.

Making Custom Watermarks Available to All Workflows
When creating a workflow with Podcast Composer, in the Edit stage, you can add a 
watermark to your podcast by dragging the watermark onto the icon of the input 
movie (see “Adding a Watermark and an Introduction Overlay” on page 23).

Every time you drag a watermark onto the icon of the input movie, the watermark 
is added to the workflow and appears in the Watermark pop-up menu of the input 
movie dialog.

However, these watermarks are available only to the workflow you are editing. If you 
open a new workflow, these watermarks won’t appear in the Watermark pop-up menu.
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To make watermarks available to all workflows in Podcast Composer:
	 1	 If Podcast Composer is open, close it.

	 2	 Copy the watermarks to the following folder:

~/Library/Application Support/Podcast Composer/Resources/Images/Watermark/

	 3	 Start Podcast Composer.

	 4	 Verify that you see the names of the custom watermarks in the Watermark pop-up 
menu.

Customizing the Email Template
Podcast Composer uses an email template to compose email notifications. This 
template resides inside the Podcast Composer application bundle (/Applications/
Podcast Composer/Contents/Resources/Materials/Templates/Mail/).

You can customize the template in two ways:

Modifying the images used by the default email templateÂÂ

Modifying the template itself, which is not recommended unless you have the ÂÂ
requisite knowledge

To customize the email template:
	 1	 Locate the Podcast Composer email template bundle:

/Applications/Podcast Composer/Contents/Resources/Materials/Templates/Mail/Apple 
Podcast.pmu

	 2	 Copy the email bundle “Apple Podcast.pmu” to the following folder:

~/Library/Application Support/Podcast Composer/Resources/Templates/Mail/

	 3	 To customize the images used by the email template, replace the contents of the 
PodcastCapture.png and Spacer.png files with your own content.

	 4	 To customize the actual email template, edit the HTML code in the following file:

~/Library/Application Support/Podcast Composer/Resources/Templates/Mail/Apple 
Podcast.pmu/Contents/Resources/Templates/part.html.erb

When editing this file, take extra caution. If this file is not edited properly, email 
notifications can fail.
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